第一章 网络控制台系统简介

网络控制台是对机房维护与监控的完美结合，必将成为机房管理员的有力助手。拥有网络控制台系统，您便可以分享到功能强大的机房维护客户控制技术，使您的工作变得更加轻松！

1.1监控构成

网络控制台由两部分构成：教师端和学生端。

教师端是指已安装硬盘保护控制台，单独安装教师端程序。

学生端是指已安装硬盘保护控制台，单独安装学生端程序。

1.2网络控制台主界面布局

网络控制台界面

1.3网络控制台的功能

网络控制台系统功能包含客户端监视和客户端控制两大功能模块。监视模块可以查看客户机实时属性或者历史属性、监视客户端恶意进程、软硬件资产和网络状态；控制模块可以对被控端进行远程重启、远程唤醒、远程关机、时钟同步、屏幕监看、屏幕广播以及对所有学生端计算机发送消息，锁定客户端键盘鼠标、屏蔽客户端外网和全部网络等操作。


第二章 安装和卸载

2.1软件安装

网络控制台系统是由教师端和学生端两部分组成。

1． 在Windows操作系统下执行网络控制台setup程序来进行安装，教师端。

2． 下一个页面是关于网络控制台系统的使用协议，请仔细阅读，然后点击接受。如果您想继续安装过程，您必须接受这一协议。

3、然后选择安装路径，您可以将安装文件保存在默认位置或输入新的路径。

4、安装完成后，用户不需要重启计算机就可以使用网络控制台。

5. 在Windows操作系统下执行setup程序，选择安装网络控制台学生端。

6. 下一个页面是关于网络控制台系统的使用协议，请仔细阅读，然后点击接受。如果您想继续安装过程，您必须接受这一协议

7. 然后选择安装路径，您可以将安装文件保存在默认位置或输入新的路径

8.安装网络控制学生端需要重启计算机。

注意：教师端必须关闭网络防火墙，第三方防火墙，以管理员身份运行才可以使用。

2.2软件卸载

网络控制台卸载可以通过以下方式：

1、 通过【控制面板】【添加或删除程序】卸载网络控制台。

通过【开始菜单】【程序】【网络控制台学生端或教师端】【卸载网络控制台学生端或者教师端】菜单卸载。


第三章 登录学生端

3.1 设置扫描网段

必须设置客户端的IP地址范围才可以进行客户端扫描，网络控制台仅会扫描‘扫描网段’内活动的学生端计算机。添加的网段对应的子网掩码也必须正确设置。

扫描网段的添加：

打开网络控制台主界面，单击菜单栏【常规】选项卡（键盘Alt+G），单击【设置扫描网段】（键盘A），在弹出的扫描网段设置对话框中输入需要扫描的网段（客户端IP地址范围）和子网掩码，单击【添加】按钮，单击【确定】按钮完成添加。

扫描网段的删除：

单击【删除全部】按钮，删除所有已存在的网段，或者勾选网段列表中已存在的网段，单击【删除】按钮删除选中的网段。此操作是可恢复的，如果用户错误的删除了不应删除的网段，那么单击【取消】按钮可以撤销本次操作。

注意：以上操作在点击确定按钮后有效。


3.2 输入登录密码

学生端默认登录密码为：dell，网络控制台仅能扫描和控制与输入密码相同的计算机。使用过程中程序会记住最后一次输入的密码；退出网络控制台后用户输入的密码将自动被清空（本机不会存储任意客户端的任何密码信息，如修改学生端密码，需要在学生端修改密码后打开硬盘保护控制台进度管理，创建进度保存）。

单击菜单栏【常规】（键盘Alt+G），单击【输入登录密码】（键盘Ctrl+P），输入密码点击【确定】按钮。


3.3 扫描计算机与登录客户端

用户可以开启网络控制台的扫描，扫描发现扫描网段内活动的客户端计算机。网络控制台可以将扫描到的客户端计算机添加到学生端列表。学生端列表会一直存储在控制端计算机中，除非用户对网络控制台进行了卸载。控制端仅能控制学生端列表中的客户端计算机。首次使用同方易教资产管理系统，因为学生端列表为空，用户必须通过扫描计算机并将扫描到的客户端计算机添加到学生端列表方可进行后续的操作。点击工具栏‘扫描计算机’扫描客户端计算机：

扫描计算机

完成扫描

点击【扫描计算机】后按钮会变为‘完成扫描’，待所有计算机都被扫描上来后，点击【完成扫描】按钮，然后选择是否将扫描到的客户端计算机添加到学生端列表。

如果学生端列表列表不为空，可以点击【登录】按钮对学生端计算机开始连接控制。3.4 普通计算机、未登录学生端和登录学生端的区分

在计算机列表中三种状态的计算机，分别为非受控计算机显示“普通计算机”图示： 说明: nomarl ，用户不能对该计算机进行任何监视和控制。未登录的学生端显示“未登录”图示： 说明: download ，用户仅可以对其进行网络唤醒（该计算机必须支持此功能）。登录的学生端显示“登录”图示： 说明: online ，用户可以使用网络控制台提供的功能进行监视和控制。3.5 添加学生端

扫描上来的普通计算机必须添加为学生端，才能被网络控制台监视与控制。用户可以将所有“普通计算机”添加为学生端，也可以选择性的添加。以下为添加学生端的两种方式：

1.完成扫描按照提示添加学生端

2.通过列表右键菜单添加学生端

单击【完成扫描】，如果存在普通计算机（非学生端计算机在计算机列表状态列显示），会弹出提示添加学生端对话框。单击【是】将所有普通计算机添加为学生端，单击【否】，放弃添加所有普通计算机。还可以通过在计算机列表中单选或者多选普通计算机，单击鼠标右键选择【添加学生端】。


3.5 删除学生端

在计算机列表中可以通过鼠标选择一个或多个学生端，单击鼠标右键选择【删除学生端】删除选中的学生端。


第四章 客户端监视设置


4.1资产监视设置

在非监控状态（登录学生端之前）可以设置需要监视的资产。资产监控默认监视硬件、软件、进程、网络。用户可以更改监视的轮询时间（信息更新的时间间隔）或者取消某一项资源的监控。如果取消某一项资源的监控，那么相应的计算机列表中相应的列显示状态为“未知”，该资源的改变将不受网络控制台系统的监视。如果学生端某一项资源与上次登录时没有发生改变则显示为“正常”，否则显示为“异常”。异常状态参考查看学生端异常状态。

单击菜单栏【客户端监视设置】（键盘Alt+S），选择【资产监视设置】（键盘A），弹出资产监视设置对话框，设置相应选项。


4.2恶意进程监视设置

恶意进程监视设置是实时生效的，无需重新登陆学生端。对监视到的客户端恶意进程有两种处理模式：自动结束和界面报警。被设置自动结束的恶意进程，将会在客户端检测到之后强行终止。设置为界面报警的进程被检测到后，控制端在计算机列表的进程状态列中显示“警告进程”，用户可以通过【资源栏】中【进程】列表查看警告进程详细），如果需要结束该进程可以选择【资源栏】中进程选项卡，在进程列表中选择相应的进程单击鼠标右键，选择菜单中的结束进程操作。

输入的进程名称必须是完整的，比如xxx.exe或者1exploere 。

单击菜单栏【客户端监视设置】（键盘Alt+S），选择【恶意进程监视设置】，弹出恶意进程监视设置对话框。

添加报警进程：

输入恶意进程名称，单击【添加】按钮，单击【确定】按钮。在已添加列表属性列中显示对该进程的处理类型。

添加主动结束进程：

输入恶意进程名称，勾选【恶意进程将被自动结束】，单击【添加】按钮，单击【确定】按钮。在已添加列表属性列中显示“结束”属性。

删除恶意进程设定：

在恶意进程设置界面中，单击【删除全部】，可以删除所有已添加的恶意进程（不需要勾选进程操作）。也可以勾选单个或者多个进程，单击【删除】，删除勾选的恶意进程。注意，删除的操作是可以恢复的，如果用户想取消以上的操作，点击取消按钮直接退出本界面。点击【确定】后恶意进程设置将被真实删除。


4.3 网络监视设置

网络状态监视功能可以对客户端的网络状态进行实时监测。在网络监视设置中，可以设置开启对客户端ARP扫描攻击进行监控（默认开启），还可以设置客户端网络流量异常的阈值（默认为100kb/s），客户端IP链接数异常阈值（默认为32），开启监测后，一旦学生端的网络流量，IP连接数超过了设定的阈值，同方易教资产管理系统将进行报警：在学生端登录列表栏中客户端的网络状态属性显示为“异常”。可以双击该客户端的相应属性字段查看该客户端的网络流量信息（参考查看学生端异常状态）。

在主菜单中选择【客户端监视设置】（键盘Alt+S），然后选择【网络监控设置】（键盘N），可以打开‘网络监视设置’对话框。


第五章 学生端监视


5.1 查看学生端资源

对于处于登录状态的学生端在资源栏中显示的是该客户端当前的信息，对于处于非登录状态的学生端，资源栏将用于显示该客户端的历史信息。资源栏中包括学生端的基础信息、软硬件信息、网络信息和进程信息。

在网络控制台界面，点击【登录】后将开始对登录列表中的计算机进行监控。网络控制台将根据‘资产监视设置’设定的查询时间间隔获取客户端的软硬件，进程及网络信息，并将获取的客户端当前信息与客户端的历史信息对比，或者判定是否客户端的实时信息是否已经超过了设定的阈值并产生报警信息。

当客户端的某一属性异常，那么该客户端该属性将会显示为‘异常’，否则该客户端的该属性将显示‘正常’，如果网络控制台在一定时间内未能获得该客户端的某一属性信息，那么该属性字段将会显示‘未知’。客户端各个属性的详细信息在‘资源栏’中显示，单击某一客户端，资源栏中将切换到该客户端的各个属性信息，可以在资源栏中切换属性页查看该客户端的各个属性信息（参考查看学生端异常状态）。

可以在主菜单中‘查看’菜单项中勾选‘资源栏’打开‘资源栏’的显示。

提示：在资源栏中的‘进程’属性页，可以在选中某一客户端进程后，通过右键菜单选择【结束进程】，结束该进程。


5.1.1 查看某一客户端的状态信息

在登录列表中单击某学生端，在资源栏中选择‘状态’属性页。

查看某一客户端的硬件信息

在登录列表中单击某学生端，在资源栏中选择‘硬件’属性页。

查看某一客户端的软件信息

在登录列表中单击某学生端，在资源栏中选择‘软件’属性页。

查看某一客户端的网络信息

在登录列表中单击某学生端，在资源栏中选择‘网络’属性页。

查看某一客户端的进程信息

在登录列表中单击某学生端，在资源栏中选择‘进程’属性页。


5.2 查看学生端异常状态


5.2.1学生端IP地址改变

若某客户端当前使用的IP地址发生了变化，在客户端登录列表栏中该客户端IP地址属性字段会出现黄色惊叹号报警。双击该属性，在弹出的‘更新信息’对话框中能查看给客户端的IP变化详细。可以在‘更新信息’界面选择取消对该客户端的IP地址变更的报警。


5.2.2学生端硬件信息改变

学生端硬件信息与上次保存信息不一致（学生端的硬件发生变化），那么客户端登录列表该客户端的硬件属性字段将会出现黄色的惊叹号报警。双击该字段，在弹出的‘更新信息’对话框中能看到新增的或者移除的硬件信息。可以单击更新信息对话框中【接受】，取消该报警。

学生端软件信息改变：

学生端软件信息与上次保存信息不一致（学生端的软件发生变化），那么客户端登录列表该客户端的软件属性字段将会出现黄色的惊叹号报警。双击该字段，在弹出的‘更新信息’对话框中能看到新增的或者移除的软件信息。可以单击更新信息对话框中【接受】，取消该报警。

学生端网络状态异常：

学生端网络状态属性有四种：屏蔽外网、禁用网络、异常和正常，前面两种状态是网络控制台系统已经对该客户端进行了网络屏蔽（参考屏蔽外网、禁用网络），异常状态表式该客户端的网络行为发生异常（网络属性字段出现黄色惊叹号报警），双击该学生端网络状态属性，在弹出网络信息对话框可以看到该学生端实时的网络状态统计信息。

学生端进程状态异常：

学生端计算机中出现已经预先设置的恶意进程。在登录列表中学生端的进程属性字段会出现黄色惊叹号报警。可在登录列表中选中该客户端后，在资源栏中选择进程属性页查看该学生端的进程资源列表。在进程列表中，可以选中该进程后，右键点击该进程，在弹出的右键菜单中执行进程删除操作（结束客户端该进程）。

学生端保护状态：

当学生端硬盘保护控制台磁盘保护驱动处于正常中工作状态时，已登录的学生端保护状态属性字段显示为“是”，否则显示“否”。


5.3 学生端信息更新

当学生端信息与历史信息不一致时，网络控制台会对该客户端的相应属性字段进行报警提示，用户可以取消该报警信息。双击该属性字段，在弹出的‘更新信息’对话框中显示了相应的更新信息，点击【接受】以接受学生端的信息变化，网络控制台将更新该客户端的历史信息，以后不再对该属性信息中的相应项作出报警。勾选【应用于所有计算机】，则存在相同信息变化（如，软件更新）的学生端的历史信息将同时被更新，网络控制台以后将不再对所有学生端的该属性的信息中的相应项进行报警。

注意：若存在IP地址冲突的学生端，则更新信息无法保存。


5.4 查看日志

在监控日志中用户可以查看学生端在监控时间内发生的事件。日志是保存在内存中的，重新启动网络控制台系统，在监控日志中可以看到的事件有：掉线、发起Arp攻击等。

单击菜单栏【常规】中的【日志】，弹出日志信息对话框。


第六章 客户端控制


6.1 屏幕监控

通过网络控制台可以实时（循环）监视一个或多个学生的电脑屏幕画面。

选择菜单栏中【客户端控制】，【屏幕监控】，点击【屏幕监看】选择【窗口数量】，屏幕监看到客户端机器的桌面。


6.2 屏幕广播

通过网络控制台【屏幕广播】，将“教师机”的屏幕图象内容同步广播到网络上的“学生机”上。


6.3 时间同步

将学生端的系统时钟设置为控制端的系统时钟。

可以在资源栏中的‘基础’属性页中查看学生端的系统时间。


6.4 远程重启、关机、唤醒操作

用户可以通过网络控制台系统对某一台或者所有学生端执行重启、关机、唤醒命令。

注意：唤醒操作需要学生端主板支持，并已经打开了相关选项。

工具条操作：

工具条的按钮对登录列表中的所有学生端进行操作。

右键菜单操作：

右键菜单对选择的部分学生端进行操作，在登录列表中选中部分学生端后在选择范围内点击鼠标右键弹出右键菜单。


6.5 发送消息

对所有在线的学生端发送广播消息，消息将以气泡的形式出现在学生端屏幕右下角。

单击工具栏中的【发送消息】，在弹出的发送短消息对话框中输入消息，单击【发送】完成操作。

消息发送：

学生端消息提示：


6.6 文件传输

将教师端的文件发送到学生端的磁盘上,也可以将学生端的文件收集到教师端的磁盘上。

点击按钮后在弹出的对话框中选择是文件分发还是文件收集，设置好路径后，点击添加文件。选择需要操作的文件后进行分发或者收集,如下图

文件分发

文件收集

6.7 锁定、启用键盘鼠标

可以远程锁定学生端的鼠标和键盘，使之不可用。学生端重启计算机后键盘鼠标锁定状态失效。在锁定键盘鼠标命令发送成功后，被锁定学生端的鼠标/键盘属性字段将显示黄色锁和文字“锁定”，并且右键菜单中的【禁用键盘/鼠标】为勾选状态，解除锁定后将显示为“未锁定”。

处于锁定状态时的学生端右键菜单状态如下：


6. 8屏蔽外网、禁用网络与启用

用户可以屏蔽学生端的外网，使之只能访问与它属于同一网段的计算机。禁用网络则彻底屏蔽学生端与外部计算机的联系。被屏蔽外网的学生端，在网络状态属性字段显示为“屏蔽外网”，并且在右键菜单中的【屏蔽外网】为勾选状态，被禁用网络的学生端，在网络状态属性字段显示为“禁用网络”，并且在右键菜单中的【禁用网络】为勾选状态。用户可以对任意一台学生端或者全部执行屏蔽外网和禁用网络的操作。

通过点击工具条按钮屏蔽所有学生端外网：

通过右键菜单屏蔽部分选中的学生端外网与禁用网络：

学生端外网被屏蔽：

学生端网络被禁用：


6.9 删除学生端进程

删除（结束）某一客户端的指定进程（参考查看学生端异常状态）。


6.10 取消登录

取消对某一学生端的网络监控。

选择一台学生端，单击鼠标右键选择菜单中的【取消登录】。


6.11 禁用、启用USB端口

禁止和启用学生端的USB存储设备的使用。

选择一台学生端，单击鼠标右键选择菜单中的【启用USB】或者【禁用USB】。