何谓 FrontPage 服务器扩展？

FrontPage 服务器扩展主要由三个程序组成，分别固定执行管理、创建和查看 等有用的任务。如果没有服务器扩展，上述任务便无法完成或无法轻易完成。

您可以很容易地在流行的操作系统中安装服务器扩展，包括 Microsoft NT 服务器、 Digital UNIX 和 SunOS。这些操作系统支持站点服务器跨平台的兼容能力。服务器扩展支持大多数流行的站点服务器，如 Microsoft Internet Information Services (IIS)、Netscape 和 WebSite，也支持免费和共享的站点服务器，如 Apache, StrongHold 和 NCSA。

您不必直接管理 FrontPage 服务器扩展。相反，您只需要使用功能相互重叠的工具中的一种即可，如 FrontPage MMC 管理单元。

有关 FrontPage 服务器扩展的详细信息，请参阅位于 http://www.microsoft.com/frontpage/wpp/serk．的 FrontPage 服务器扩展资源工具箱。 如果 FrontPage 服务器扩展安装在您的计算机上，您也可以访问 FrontPage 服务器扩展资源工具箱，它默认安装在 C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\40\Serk\nnnn\default.htm 下。\nnnn 文件夹的名称是以您安装的 FrontPage 服务器扩展的语言而定的。例如，在中文版本的安装中，路径是 C:\Program Files\Common Files\Microsoft Shared\Web ServerExtensions\40\Serk\2052\default.htm。


使用 FrontPage 服务器扩展的优点

FrontPage 服务器扩展使得站点创作者能轻易地在 Web 站点中加入复杂的功能，并使站点管理员支持这些功能。服务器扩展可以：

  • 使创作者们能协作创建和维护 、 直接在服务器计算机上编辑一个 Web 站点（节省下载时间），并且在不必编写程序的情况下，轻易地在站点上加入新功能。
  • 支持站点计数器、全文搜索、电子邮件表单处理程序和其他由创作者使用 FrontPage 添加到站点的功能。您不必下载、购买或安装独立的 兼容的程序来实现上述功能。
  • 能在许多流行的服务器平台，如 Windows NT 和 UNIX，以及许多流行的站点服务器，如 Microsoft Internet Information Services (IIS)、Apache、WebSite 和 Netscape 上工作。
  • 在一个 Web 站点中移动、删除或重命名一个网页（只是网页的文件名，而不是必须传送到站点服务器的整个文件的名称）后，自动更新超链接。
  • 支持与 Microsoft Office、Visual SourceSafe 和 Index Server 的集成。


关于 FrontPage MMC 管理单元

FrontPage MMC 管理单元是一种基于 Windows 操作系统的程序，您可以用它来管理 FrontPage 服务器扩展和 。您可以使用 MMC 来 、 创建 、升级站点上的服务器扩展、将文件夹与子站点相互转换、重新计算 中的超链接以及实现更多功能。

FrontPage MMC 管理单元嵌入在 Microsoft 管理控制台 (MMC) 中，即您要用来管理 FrontPage 服务器扩展的命令、属性表和其他工具都添加到了 MMC 外壳中。FrontPage MMC 管理单元工具看上去和用起来就象 中的其他工具一样。

如果计算机上安装了 Microsoft Internet Information Services (IIS) 4.0 或更新的版本，FrontPage MMC 管理单元将嵌入到 IIS 管理单元中；即它的功能将添加到 IIS 管理单元中。反之，如果计算机上安装了不同于 Microsoft Internet Information Services 4.0 或更新版本的站点服务器，FrontPage MMC 管理单元则会将其功能直接加入到控制台中。您要用来管理 的所有工具都放在一个很方便的位置。

FrontPage MMC 管理单元替换并大幅改进了 Fpsrvwin 工具。Fpsrvwin 工具是以前版本的 FrontPage 中包含的管理程序。您可以用 FrontPage MMC 管理单元来完成 Fpsrvwin、 Fpsrvadm 和 Fpremadm 工具完成的大部分任务以及其他一些任务。

关于如何利用 Fpsrvadm 和 Fpremadm 来管理 FrontPage 服务器扩展的内容，请参见位于 http://www.microsoft.com/frontpage/wpp/serk 的 FrontPage Server Extensions Resource Kit。 如果 FrontPage 服务器扩展安装在您的计算机上，您也可以访问 FrontPage Server Extensions Resource Kit，它默认安装在 C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\40\Serk\nnnn\default.htm 下。\nnnn 文件夹的名称是以您安装的 FrontPage 服务器扩展的语言而定的。例如，在中文版本的安装中，路径是 C:\Program Files\Common Files\Microsoft Shared\Web ServerExtensions\40\Serk\2052\default.htm。


FrontPage MMC 管理单元替换 Fpsrvwin.exe 工具：发现相异处

FrontPage MMC 管理单元替换 Fpsrvwin 工具：发现相异处

如果您使用过较早版本的 FrontPage 服务器扩展，也许曾用 Fpsrvwin 工具来管理过它们。 Fpsrvwin 是一个用来完成管理任务的工具，例如从一个站点服务器安装、检查与修复和删除服务器扩展。

FrontPage MMC 管理单元除了提供 Fpsrvwin 最常用的功能外，还可以用于：

  • 设置站点属性，如性能、电子邮件选项、脚本权限和创作日志。
  • 创建 。
  • 添加管理员。
  • 将文件夹和子站点相互转换。
  • 删除子站点。
  • 在 FrontPage 中打开 （如果 FrontPage 和站点安装在同一部计算机上）。
  • 指定默认的 。
  • 记录创作操作。
  • 重新计算超链接。


其他可用来管理 FrontPage 服务器扩展的工具

FrontPage MMC 管理单元是一个图形界面程序，您可以轻易地使用它来管理 FrontPage 服务器扩展。FrontPage MMC 管理单元替换并大幅度地改进了 Fpsrvwin 工具。Fpsrvwin 也是一个图形界面程序，它包含在以前版本的 FrontPage 软件中。然而 FrontPage MMC 管理单元只能在 Windows 操作系统中运行，并且您不能用它从 来管理服务器扩展。

FrontPage MMC 管理单元只是所有用于管理 FrontPage 服务器扩展的工具中的一种。下面列出的另外三种工具提供和 FrontPage MMC 管理单元几乎一样的功能，但却能在管理单元无法工作的操作系统下运行：

  • Fpsrvadm　工具是个命令行程序，可用于 Windows NT 和各种 UNIX 操作系统。您可以使用这个工具来执行 。Fpsrvadm 在您安装 FrontPage 服务器扩展时也安装在计算机中。您不能从远程计算机使用 Fpsrvadm 来管理服务器扩展。
  • Fpremadm 工具是个命令行程序，您可用它从远程计算机管理 FrontPage 服务器扩展。然而，Fpremadm 仅能在 Windows NT 工作站、Windows NT 服务器和 Windows 95/98 等操作系统中运行，而不能在 UNIX 操作系统如 Linux 和 SunOS 上运行。Fpremadm 在您安装 FrontPage 服务器扩展时也安装在计算机中。
  • HTML 管理表单是 HTML 表单，您可以用它们从 Web 浏览器远程管理 FrontPage 服务器扩展。

有关这些工具更进一步的信息，请参阅 http://www.microsoft.com/frontpage/wpp/serk 处的 FrontPage 服务器扩展资源工具箱。


用 FrontPage MMC 管理单元能完成的管理任务

用 FrontPage MMC 管理单元所能完成的管理任务

您可以使用 FrontPage MMC 管理单元完成下列任务：

  • 在站点服务器上安装 FrontPage 服务器扩展。
  • 使用 FrontPage 服务器扩展来 一个 。
  • 检查并修复 上的 FrontPage 服务器扩展。
  • 升级站点上的 FrontPage 服务器扩展。
  • 删除站点上的 FrontPage 服务器扩展。
  • 删除用 FrontPage 服务器扩展所扩展的 。
  • 将子站点和文件夹相互转换。
  • 重新计算站点中的所有超链接。
  • 添加网页管理员。
  • 启用或禁用站点创作。
  • 调整 。
  • 记录创作操作。
  • 创作需要 协议。
  • 指定可以包含可执行 或程序的文件夹。
  • 启用 。
  • 设置电子邮件选项。

您不能用 FrontPage MMC 管理单元完成下列任务：

  • 从 管理 FrontPage 服务器扩展（可使用 Fpremadm 工具）。
  • 执行 （可使用 Fpsrvadm 工具）。


可以找到用于管理 FrontPage 服务器扩展的 FrontPage MMC 管理单元组件的地方

您需要用哪个 FrontPage MMC 管理单元菜单、命令、对话框或其他组件来完成任务？您又能在什么地方找到这些组件？

您要用三个主要组件来管理 FrontPage 服务器扩展：

  • “新建” 菜单，您可以从中选择命令来创建一个 、添加一位新管理员等等，这取决于您在 中的选择。
  • “任务” 菜单，您可从中选择命令来检查与修复、删除和升级 FrontPage 服务器扩展，如同执行其他任务一样。同样地，您在控制台树中选择的项目将决定出现在“任务”子菜单中的命令。
  • “服务器扩展” 选项卡允许您修改 FrontPage 服务器扩展的设置，如电子邮件选项和安全设置。

下面的表格列出了可使用 FrontPage MMC 管理单元来完成的管理任务、每个任务要使用的工具和该工具的位置。只有当站点服务器是 Microsoft Internet Information Services (IIS) 4.0 或更新版本时，括号中的名词才会出现。

任务 | 工具及其位置
用服务器扩展来扩展一个虚拟服务器（IIS 4.0 或更新版本） | 快捷菜单>“任务”>“配置服务器扩展”
用服务器扩展来扩展一个虚拟服务器（非 IIS 和 IIS 3.0） | 快捷菜单>“新建”>“站点”
创建子站点 | 快捷菜单>“新建”>“服务器扩展站点”
添加管理员 | 快捷菜单>“新建”>“服务器扩展管理器”
检查与修复站点及其底下子站点的服务器扩展 | 快捷菜单>“任务”>“检查服务器扩展”
升级站点的服务器扩展 | 快捷菜单>“任务”>“升级服务器扩展”
删除根站点及其子站点的服务器扩展 | 快捷菜单>“任务”>“删除服务器扩展”
重新计算站点中所有的超链接 | 快捷菜单>“任务”>“重新计算站点”
删除子站点 | 快捷菜单>“任务”>“删除站点”
将文件夹转换为子站点 | 快捷菜单>“任务”>“将目录转换为站点”
将子站点转换为文件夹 | 快捷菜单>“任务”>“将站点转换为目录”
启用或禁止创作 | 快捷菜单>“属性”>“服务器扩展”选项卡 >“启用创作功能” 复选框
启用版本控制 | 快捷菜单>“属性”>“服务器扩展”选项卡>“版本控制”框
调整站点性能 | 快捷菜单>“属性”>“服务器扩展”选项卡>“性能”框
指定默认生成的脚本语言 | 快捷菜单>“属性”>“服务器扩展”选项卡>“客户脚本”框
设置电子邮件选项 | 快捷菜单>“属性”>”服务器扩展”选项卡>“设置”
应用父站点安全设置到子站点 | 快捷菜单>“属性”>“服务器扩展”选项卡>“不要继承安全设置”复选框
记录创作操作 | 快捷菜单>“属性”>“服务器扩展”选项卡>“记录创作操作”复选框
人工设置权限 | 快捷菜单>“属性”>“服务器扩展”选项卡>“手工管理权限”复选框
创作需要 SSL 协议 | 快捷菜单>“属性”>“服务器扩展”选项卡>“创作需要 SSL 协议”复选框
指定文件夹是否包含可执行脚本或程序 | 快捷菜单>“属性”>“服务器扩展”选项卡>“允许作者上载可执行程序”复选框


FrontPage 中的权限模式

为了帮助您管理对站点服务器上 的访问，FrontPage 提供了一个简单的基于角色的 模式和设置权限的有用工具。基于角色的模式，简单地说，就是授予用户的权限取决于用户的角色（用户可以是人、组或计算机）。

对于站点服务器上的每个 ，您可以为下列三种角色的用户设置权限：

  • 访问者，可授予浏览权限，此权限可以查看并使用已发布到站点服务器上的 FrontPage 扩展站点。
  • 创作者，可授予创作权限，此权限可以打开一个 FrontPage 扩展站点并修改其内容。
  • 管理员，可授予管理权限，此权限可从 FrontPage 扩展站点添加、升级或删除 FrontPage 服务器扩展，包括创建或删除 、记录创作操作、为其他用户设置权限以及执行其他管理任务。

FrontPage 扩展的站点的权限是阶层式的：用户如果具有管理权限，则他亦具有创作和浏览权限。用户如果具有创作权限，则他亦具有浏览权限。

在默认的情况下，您所设置的站点权限将被其底下的子站点继承。当然您也可以针对每个子站点设置其权限，在这种情况下，对子站点设置的权限将取代从其父站点继承的权限。用这种方式，您可以对每个用户和组指定不同层级的访问每个子站点的权限。例如，您可以授予一个用户以创作一个子站点的权限，但对于另一个子站点可只授予他浏览权限。

您可以对什么样的用户设置权限呢？这完全取决于您的站点服务器。Microsoft Internet Information Services (IIS) 由 Windows NT 用户帐户列表中获得用户帐号。因此您不必创建新用户帐号，而只需设置列表中的用户权限即可。对于其他站点服务器，使用的帐号由站点服务器集中管理，因此您可自行创建新的用户帐号。

您可以使用 FrontPage 服务器扩展工具，如 Fpsrvadm， 也可以使用“工具”菜单中的“权限”命令来为 Frontpage 中的站点设置权限。


FrontPage MMC 管理单元如何工作在不同的站点服务器上

如果您同时使用 Microsoft Internet Information Services (IIS) 和其他站点服务器，如 Apache、WebSite 和 Netscape，可能知道 FrontPage MMC 管理单元在 IIS 4.0 和更新版本上的工作方式跟在其他站点服务器（包括 3.0）上不同。

IIS 4.0 或更新版本的管理单元嵌入到 Microsoft 管理控制台 (MMC) 中。FrontPage MMC 管理单元在结构上嵌入到 IIS4.0 或更新版本的管理单元中。所以如果 IIS 4.0 或更新版本安装在一台计算机上，那么 FrontPage 管理单元的功能将和 IIS 的功能完全集成在一起。

如果您从前曾使用过 IIS 的 MMC 管理单元，您也许注意到某些命令已被加入到“操作”和快捷菜单中，而且“服务器扩展”属性页已加入到“属性”表中。FrontPage MMC 管理单元也增加了此新功能。当两者的功能互相重叠时，则将出现 IIS 的命令而不是 FrontPage 管理单元的命令。在 中，IIS 列出了所有的 IIS , 包括 和其他站点。

如果 FrontPage MMC 管理单元和其他非 IIS 4.0 或更新版本的站点服务器安装在同一台计算机，其功能将不会与站点服务器的集成在一起。事实上，该站点服务器也许甚至没有能将其功能添加到控制台的 MMC 管理单元。在这种情况下，控制台树仅列出 FrontPage 扩展站点， 而不列出计算机上所有的站点。

有时候，IIS 4.0 或更新版本和其他站点服务器同时安装在同一台计算机上。在这种情况下，您将看到每一个站点服务器最上层的项目，其站点列在该项目的底下。当您选择一个位于 IIS 4.0 或更新版本的站点服务器上的 ，并显示快捷菜单时，将看到 IIS 管理单元命令和 FrontPage 管理单元命令一起出现。当您选择一个非 IIS 站点并显示快捷菜单时，您将看到用于管理 FrontPage 服务器扩展的命令仅来自 FrontPage MMC 管理单元。


用 FrontPage 服务器扩展来扩展虚拟服务器

当您创建了 后，可以使用 FrontPage 服务器扩展来 它，使该虚拟服务器成为 。在扩展虚拟服务器之前，服务计算机上必须安装服务器扩展。

用 FrontPage 服务器扩展来扩展虚拟服务器

  1. 在 中右击您要扩展的虚拟服务器。
  2. 单击快捷菜单上的“任务”，然后单击“配置服务器扩展”。

如果安装的站点服务器并非 IIS 4.0 或更新版本，请单击快捷菜单上的“新建”，然后单击“站点”。

  3. 遵循“发布扩展配置向导”中的步骤。

注意

您如果要在一个虚拟服务器底下创建 ，则必须先将其扩展，即使它成为根站点。


创建子站点

这里的子站点指的是 底下的一个文件夹或本身就是一个已创建完成的 的子站点。它是对一个完整的 内容的逻辑划分。

子站点允许您指定独立的管理、创作和浏览 、将站点内容按逻辑拆分为多个组成部分以提高性能、对每个子站点的网页应用不同的外观并且很容易地管理超链接。

您可以只在根站点或子站点上创建子站点，也可以在根站点或子站点下的文件夹中创建子站点。当您创建子站点时，可以同时用 FrontPage 服务器扩展来 它。系统为每个子站点自动创建一个文件夹。

创建一个子站点并用 FrontPage 服务器扩展来扩展它

  1. 在 中右击您要创建子站点的 （或文件夹）。
  2. 单击快捷菜单上的“新建”，然后单击“服务器扩展站点”。

如果所安装的站点服务器并非 IIS 4.0 或更新版本，请单击快捷菜单上的“新建”，然后单击“站点”。

  3. 遵循“新建子站点向导”中的步骤。


添加管理员

如果您忘记了密码或想要其他人也能管理站点，则可以添加一个站点管理员。

添加管理员

  1. 在 中右击您要添加管理员的 。
  2. 单击快捷菜单上的“添加”，然后单击“服务器扩展管理器”。

如果所安装的站点服务器并非 IIS 4.0 或更新版本，请单击快捷菜单上的“添加”，然后单击“管理器”。

  3. 在 “用户名” 框中输入一个 Windows NT 帐号，作为一个管理员添加到站点。

如果安装的站点服务器并非 IIS 4.0 或更新版本，可在 “用户名” 框中输入用户名称，并在 “密码” 和 “确认密码” 框中输入相同的密码。


删除根站点和其底下子站点的 FrontPage 服务器扩展

有时候您或 创作者也许会决定某个站点不再需要包含 FrontPage 服务器扩展。在这种情况下，您可以从该 删除服务器扩展，该站点下的 中的服务器扩展也将一起被删除。

当您删除服务器扩展后，FrontPage 服务器扩展提供的任何功能，如访问计数器和电子邮件表单处理程序，将不再起作用，但站点内容还在，只是服务器扩展被删除。

删除根站点及其子站点的 FrontPage 服务器扩展

  1. 在 中右击您要删除服务器扩展的根站点。
  2. 单击快捷菜单上的 “任务”，然后单击 “删除服务器扩展”。

在默认情况下，包含站点结构信息和主题等的文件不会被删除。这样，在您以后要再次扩展该站点时便可立刻将它重建为现在的样子。但如果您永远不再需要该站点的 FrontPage 服务器扩展，请清除 “保存站点的 meta 信息供以后升级或重新安装 Frontpage 服务器扩展时使用” 复选框。

  3. 单击 “确定”。


检查并修复站点或子站点上的 FrontPage 服务器扩展

有时候一个 创作者也许不能上载网页内容、直接在服务计算机上修改站点或实现其他 FrontPage 服务器扩展支持的功能。问题的根源可能在于不小心删除或重命名了重要文件，也可能在于破坏了 。若要修复设计阶段错误，您可以使用“检查服务器扩展”命令。该命令

  • 检查只读 。
  • 检查 Service.cnf 和 Service.lck 是只读还是可写。
  • 更新 Postinfo.html 和 _vti_inf.htm。
  • 检查是否安装了 _vti_pvt、_vti_ log 和 _vti_bin 以及 _vti_bin 是否可执行。
  • 确定 的 roots 或 metabase 设置是否正确以及是否被更新。
  • 检查 IUSR 匿名帐号不拥有写入权
  • 当在 FAT 文件系统下运行时发出警告，也就是说您不能应用任何站点安全设置（如果您正在运行 IIS）。

检查并修复 FrontPage 服务器扩展

  1. 在 中右击您要检查并修复 FrontPage 服务器扩展的站点。

该站点将被检查并修复，包含其底下所有的 。

  2. 单击快捷菜单上的“任务”，然后单击“检查服务器扩展”。

检查站点视窗将显示每个站点检查后的状态记录。


升级站点的 FrontPage 服务器扩展功能

随着时间的推移，新版本的 FrontPage 服务器扩展将出现。新的版本能提供站点创作者和管理员以更多的支持，或适应当前现有的特性，同时也支持 FrontPage 现有的功能，如访问计数器。

为享用新功能所带来的好处，您必须首先在服务器计算机上安装最新版的服务器扩展，然后将 升级到这个版本。您可仅升级 上的服务器扩展，但这样将同时升级其底下的所有 。

将 FrontPage 服务器扩展升级到最新版本

  1. 在 中右击您要将其服务器扩展升级的根站点。
  2. 单击快捷菜单上的“任务”，然后单击“升级服务器扩展”。

注意

只有在有较新的服务器扩展版本时，“升级扩展”命令才会显示。

若要升级计算机中所有根站点的 FrontPage 服务器扩展，请右击控制台树中的“我的电脑”。


删除用 FrontPage 扩展的子站点

一个 可能因过期、很少使用或其他原因而不再需要。例如，其信息已发布到公司的 intranet 上的项目已经到期或重新被组织，或者， 向 Internet 服务提供商的站点服务器上发布了 的订户已被终止。在这些或其他情况下，您可能需要删除该子站点。

当您删除一个子站点时，将删除该子站点所有的内容、文件、文件夹和嵌套子站点，同时也将删除该子站点的 FrontPage 服务器扩展。您不能恢复删除了的子站点。

删除子站点

  1. 在 中右击您要删除的子站点，然后单击“删除”。
  2. 在快捷菜单上单击“任务”，然后单击“删除站点”。
  3. 最后单击“确定”。

注意

如果您不具有删除该子站点底下嵌套子站点的权限，则该嵌套子站点不会被删除。


将站点中的文件夹转换为子站点

如果您确定一个文件夹中包含了足以建立自己的 的站点内容（如 Web 页或图形），那么您可轻易将该文件夹转换为 。在效果上，这是创建 的方法之一。

将文件夹转换为子站点

  1. 在 中右击您要将其转换为用 FrontPage 扩展的子站点的文件夹。
  2. 单击快捷菜单上的“任务”，然后单击“转换为站点”。

如果所安装的站点服务器并非 IIS 4.0 或更新版本，请单击快捷菜单上的“任务”，然后单击“转换为站点”。


将子站点转换为文件夹

有时候您也许觉得不再需要某个 ，但又希望保留其网页内容。在这种情况下，您可以将该 转换为其 中的一个文件夹。当您将一个子站点转换为一个文件夹时，FrontPage 服务器扩展将从该子站点中删除。该子站点转换成其父站点下的一般文件夹。同时，该子站点底下的子站点也连接到相应的父站点。

被转换的子站点底下的子站点也许将取得不同的主题 设置。如果被转换的子站点底下没有子站点，则该子站点中的所有网页也许会失去一些网页属性。

将子站点转换为文件夹

  1. 在 中右击您要转换为一般文件夹的用 FrontPage 扩展的子站点。
  2. 单击快捷菜单上的“任务”，然后单击“服务器扩展站点转换为目录”。

如果所安装的站点服务器并非 IIS 4.0 或更新版本，请单击快捷菜单上的“任务”，然后单击“将站点转换为目录”。


使用 FrontPage 打开站点

作为一名管理员，您有时候也许要改变 或 的主题、文本、图形或其他内容。如果 FrontPage 和 或子站点安装在同一台服务器计算机上，那么您可以在 FrontPage 中从 直接打开站点并改变其内容或执行其他操作。否则，您不能从控制台打开一个站点。

使用 FrontPage 打开站点

  1. 在 中右击您要在 FrontPage 中打开的站点。
  2. 单击快捷菜单上的“任务”，然后单击“用 FrontPage 打开”。
  3. 在 FrontPage 中，修改站点内容并保存修改结果。

注意

如果服务器计算机上未安装 FrontPage，则“用 FrontPage 打开”命令不会出现。


重新计算站点中所有的超链接

任何改变 结构的操作均足以改变该站点不同部分间的链接。例如，如果添加一个网页、重命名文件夹或从一个文件夹移动到另一个文件夹，则站点中每个链接到该网页的超链接便需要更新或重新计算，以重新创建其逻辑链接。FrontPage 将自动重新计算超链接。您也可以强制 FrontPage 重新计算超链接。

重新计算站点中所有的超链接

  1. 在 中右击您要重新计算超链接的站点。
  2. 单击快捷菜单上的“任务”，然后单击“重新计算站点”选项卡

如果您正在运行 IIS 4.0或更新版本并已选定一个子站点，请单击快捷菜单上的“任务”，然后单击“重新计算发布的站点”。


指定默认生成的脚本语言

为响应特定的创作操作，FrontPage 服务器扩展将生成客户端脚本。在默认情况下，服务器扩展用 JavaScript 生成这些脚本。JavaScript 可在两个最流行的站点浏览器（Netscape Navigator 和 Microsoft Internet Explorer）或其他的浏览器上执行。您也可以选择以 VBScript 生成脚本，但 Netscape Navigator 并不识别 VBScript。然而在某些时候 VBScript 也许是您的选择，例如，如果您公司的 intranet 只使用 Internet Explorer，或者您公司内的技术人员选择 VBScript 作为脚本语言。

指定默认生成的脚本语言

  1. 在 中右击您要指定默认生成脚本语言的文件夹。
  2. 单击快捷菜单上的 “属性”，然后单击 “服务器扩展” 选项卡。
  3. 在 “客户脚本” 框中选择一种脚本语言。


人工设置权限

基于角色的 可以用来设置并管理每个 权限，包括管理员、创作者和 访问者权限，但使用 FrontPage 自动设置的方式也许无法每次都能满足您的需要。例如，您也许要设置文件和文件夹的权限。您可以通过直接设置 权限来人工设置自定义权限。有关设置自定义权限的更多信息，请参阅 FrontPage Server Extensions Resource Kit，其站点是：http://www.microsoft.com/frontpage/wpp/serk。

但是，如果您使用 FrontPage 来管理用户权限，复位 ACL 将改变任何您设置的自定义权限。若要确保任何人不会意外地更改自定义权限，您可以禁用 FrontPage 中的权限。

人工设置权限

  1. 在 中右击您要人工设置权限的站点。
  2. 单击快捷菜单上的“属性”，然后单击“服务器扩展”选项卡。
  3. 请确定“手工管理权限”复选框已被选中。


启用或禁用站点创作

的创建和频繁更新要求其创作者必须有访问权。某些包含重要或永久信息的站点一旦完成，就希望其中的数据不再改变。或者，当您正在移动站点位置或作其他更改时，不想让其他人修改该站点。若要保护站点中的信息，您可以禁用对其的创作。也就是说，其他用户既不能添加也不能改变站点内容。

启用或禁用站点创作

  1. 在 中右击您要启用或禁止创作的站点。
  2. 单击快捷菜单上的“属性”，然后单击“服务器扩展”选项卡。
  3. 若要启用创作，请确定“启用创作功能”复选框已被选中。

若要禁用创作，请确定“启用创作功能”复选框已被清除。


指定文件夹是否能包含可执行脚本或程序

当一位站点创作者要在 中包含 或 Active Server Page 时，您如何能确定该创作者加载的程序有问题，甚至更糟的是，加载病毒到站点服务器上，通过阻止创作者向 中的任何文件夹加载脚本或程序可避免此种情况的发生。

指定文件夹是否能包含脚本或程序

  1. 在 中右击您要指定是否允许上载的文件夹。
  2. 单击快捷菜单上的 “属性”，然后单击 “服务器扩展” 选项卡。
  3. 若要允许文件夹包含可执行脚本或程序，请确定 “允许作者加载可执行程序” 复选框已被选中。

为防止文件夹中可能含有可执行脚本或程序，请确定 “允许作者加载可执行程序” 复选框已被清除。


记录创作操作

拥有修改 内容的权限的用户可能更改文本、图形、链接和站点结构等等。若要跟踪谁更改了站点内容以及哪些文件被更改，您可以记录创作操作。这样系统将记录创作者执行操作的时间、创作者的名称、站点名称、远程主机和每步运算的数据，并将这些信息保存到 中名为 _vti_log/Author.log 的文件。如果安全性遭到破坏，您可以分析该日志文件以判断站点上发生了什么样的创作活动。

记录创作操作

  1. 在 中右击您要记录创作操作的站点。
  2. 单击快捷菜单上的“属性”，然后单击“服务器扩展”选项卡。
  3. 请确定“记录创作操作”复选框已被选中。


创作需要 SSL 协议

站点信息很容易在传送过程中遭到有心人士的拦截，尤其是在 的各部分间传送时。您可以通过要求以 标准在 FrontPage、Web 浏览器和站点服务器之间传送消息，从而强化传送过程以对付潜在的黑客。

创作需要 SSL 协议

  1. 在 中右击您要使用 SSL 协议的 。
  2. 单击快捷菜单上的“属性”，然后单击“服务器扩展”选项卡。
  3. 请确定“创作需要 SSL 协议”复选框已被选中。

注意

如果您创作时需要 SSL 协议，则试图在站点上工作的创作者会收到一条消息，该消息指出：他们被要求从 Frontpage 中选择使用 SSL。


调整站点性能

一个 对 FrontPage 客户端的响应速度在很大程度上依赖于站点的大小，尤其是它包含的网页和其他文件的数目。您可以通过调整来提高站点的响应速度。当您调整一个站点时，FrontPage 服务器扩展将根据该站点的网页数量为其设置一定大小的缓存。例如，您可以将一个站点调整为少于 100 网页或多于 1000 网页。您也可以自定义缓存大小和全文搜索索引大小。

调整站点性能

  1. 在 中右击您要调整性能的站点。
  2. 单击快捷菜单上的“属性”，然后选择“服务器扩展”选项卡。
  3. 在“性能”框中，选择最接近您要调整的站点中实际网页数量的网页范围。
  4. 若要自定义调整站点，请单击“使用自定义设置”，然后输入您要的缓存和全文搜索索引大小。


启用版本控制

当许多人正在修改站点内容时，您可以使用版本控制来观察谁正在修改一个特定站点文档、标记所作的更改、避免一个作者的更改删除另一个作者的更改，并且在必要时将文档返回前一版本。若要为特定的 提供版本控制功能，您可选择内置的版本控制或使用 Microsoft Visual SourceSafe 。

内置的版本控制包含在 FrontPage 服务器扩展中。您可以用它来签入和签出一个站点，以及将其返回到上次保存的版本。Visual SourceSafe 程序必须单独购买并安装到您的计算机上。该程序除了能完成内置版本控制所能完成的全部功能外，还能够跟踪更改，并且可将站点返回到任何一次修改的版本。

启用版本控制

  1. 在 中右击您要为其启用版本控制的站点。
  2. 单击快捷菜单上的“属性”，然后单击“服务器扩展”选项卡。
  3. 在 “版本控制” 框中，请选择 “使用 SourceSafe” 或 “使用内置程序”。

如果您选择“使用 SourceSafe”，则请输入您要使用的 Visual SourceSafe 项目名称。

注意

只有在 Visual SourceSafe 中的“启用 SourceSafe integration”选项打开时，您才能在 FrontPage 中使用 Visual SourceSafe 。这是个自定义安装选项。当您安装 Visual SourceSafe 时必须选择它。


设置电子邮件选项

有些特性需传送电子邮件给浏览本站点的站点访问者。常见的例子是电子邮件表单处理程序。若要能够传送电子邮件，您必须指定站点服务器的邮件地址、联系地址、SMTP 主机地址、邮件编码方式和邮件字符集。

设置电子邮件选项

  1. 在 中右击您要设置电子邮件选项的站点。
  2. 单击快捷菜单上的 “属性”，然后单击 “服务器扩展”选项卡。
  3. 在 “选项” 框单击 “设置”。
  4. 输入您要的设置值。


从微软技术支持部门获得联机支持

通过 Internet 获得技术性问题的最新解答

如果您有技术性问题，而又无法在 Windows 2000 帮助文件中找到所要的答案，请使用“联机支持”，选择您的产品，键入您的问题，然后站点便会完成其余的工作。从微软知识库中的技术性文档，到疑难解答向导和可下载文件，联机支持集中了最有可能回答您的问题的具体资源。

要开始查找，请访问 http://www.microsoft.com/china/support/。


电子邮件设置

在这个对话框中，您可以指定如何从包含基于电子邮件的特性（如表单处理程序）的站点发送电子邮件消息。

站点服务器的邮件地址

输入出现在电子邮件“发件人”行中的电子邮件地址，该消息由某些 FrontPage 组件发送，如结果表单。

联系人地址

输入当用户有问题时可供联络的电子邮件地址。您输入的电子邮件地址将出现在错误消息中，该错误消息显示 FrontPage 用户遇到的问题。

SMTP 邮件服务器

输入将消息传送至站点或从站点传送的 SMTP 主机名称。

邮件编码

选择用于邮件的编码方式。默认编码方式是 8 位 编码，此种方法也是最常见的编码方式。如果您知道邮件接收者使用不同的编码方式且对方无法解读您的消息，也许您该改变邮件的编码方式。

字符集

选择用于电子邮件消息的字符集名称。每一种字符集都是一种语言的字母表。


性能

在这个对话框中，您可为一个站点上的每种常用信息类型指定一定的缓存。通过为选定站点指定适当缓存值，您可以改善站点对用户活动的响应情况。

内存中的文档缓存设置

输入想要其属性信息（如链接图和站点参数）内存中保持为活动状态的最大文档个数。这个数字代表您指定要使用的最后一个文档。例如，如果您输入 4096，则第 4097 个文档将从内存中释放。

包含文件缓存

输入想要将其保留在内存中从而能为其他文件所用的文件个数。例如，可能有一些您要包含在 Web 站点的或所有 Web 页中的页眉、页脚和版权文件。

图像文件缓存

输入 FrontPage 服务器扩展用以在 Web 页中创建分层图片的内存中的图像文件个数。例如，一个文件也许包含背景和其他导航按钮。服务器扩展可通过向一个网页添加背景，然后重叠导航按钮图像来组成一张图片。如果组件文件存放在缓存中，则图像可以更快地组成。

全文搜索索引大小

输入可被分配用来保存全文搜索索引的最大磁盘空间。达到这个数值后，站点上的网页便不再被索引（除非您增加这个值）。

最大缓存文档大小

输入在内存中可存放的最大文档的大小。该数值限制包含可以存放在缓存中的文件、图像文件和其他文件。


默认站点属性－发布属性页

默认 Web 站点属性－服务器扩展属性页

在该属性页上，您可以设置 FrontPage 扩展站点的发布控件。

启用创作（仅根站点）

允许创作者使用 FrontPage 来访问并修改选定站点的内容。清除“启用创作功能”复选框将防止任何人访问并修改选定的站点。

版本控制

选择版本控制方法，即您要用它来跟踪谁正在修改站点内容、标记任何所作的更改，并且防止一个创作者的更改删除另一个创作者的更改。您可以选择内置的版本控制或提供更多版本控制特性的 Microsoft Visual SourceSafe 。

性能

选择最接近选定站点中网页真实数量的页面范围。FrontPage 服务器扩展将根据您选择的页面范围来留出一定数量的缓存。

客户端脚本

选择可由 FrontPage 服务器扩展在网页中自动生成的脚本语言，Jscript 或 VBScript。

指定如何传送邮件

显示“电子邮件设置”对话框，您可在该对话框中指定：基于电子邮件的站点特性，如电子邮件表单处理程序，如何将电子邮件传送给 Web 站点的访问者。您可以使用该对话框来指定站点服务器的电子邮件地址、联络电子邮件地址、邮件服务器、邮件编码方法和字符集。

配置 Office 的协作特性

显示 Office 服务器扩展管理网页，您可以从这些网页管理 Office 协作特性，如工作组讨论。如果计算机没有安装 Office 站点服务器 (OWS) 时，此选项便无法使用。

继承安全性设置（仅子站点）

将用于父站点的安全性选项应用到选定的子站点，这些选项由该复选框底下的 4 个复选框指示。如果您选择此复选框，则底下四个复选框将无法使用。如果您要让选定的子站点具有其父站点不同的安全性设置，请清除此复选框。

记录创作操作

使系统记录创作者执行操作的时间、创作者的用户名称、站点名称、远程主机和每步运算的数据，并将此信息存放在根站点 _vti_log/Author.log 中的一个日志文件中。如果您不要记录创作操作，请清除此复选框。

人工管理权限

禁用 FrontPage 服务器扩展管理工具（如 FrontPage MMC 管理单元）的安全设置功能，使得这些工具不能用来修改选定站点的安全设置。如果您要启用 FrontPage 服务器扩展管理工具改变安全设置，请清除此复选框。

创作需要 SSL 协议

使您可以用 SSL 来验证站点作者身份。如果您当前仅使用基本验证，建议采用 SSL。基本验证对在站点上传送的信息（例如创作者的用户名称和密码）仅作简单的加密处理。 如果您不需要用 SSL 协议来创作，请清除此复选框。

允许创作者加载可执行程序

允许创作者加载 CGI 脚本或 Active Server Page 到选定的站点。如果您要防止可执行程序加载到站点并避免将有问题的脚本或病毒加载到站点服务器所造成的风险，请清除此选项。